<!doctype html>
<html>
<head>
<meta charset="UTF-8"/>
<title>Watch Snoop Dogg Induct Tupac Shakur Into The Rock And Roll Hall Of Fame - Stereogum</title>
<link rel="icon" href="http://assets.stereogum.com/favicon.ico"/>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<meta name="viewport" content="width=device-width">
<link rel="alternate" type="application/rss+xml" title="RSS" href="http://www.stereogum.com/feed">
<link rel="stylesheet" href="http://www.stereogum.com/wp-content/themes/stereogum/assets/css/style.css?8fc7fede9fd1e5e28005d4f393fdc44851c131d5" type="text/css" media="screen"/>
<script language="javascript" type="text/javascript" tag="comments-vote-settings">
            var cvotesettings = {
                ncolor:"777777",
                pcolor:"222222",            
                zcolor:"cccccc",
                login_func:"openSignInDialog"                
            };
            
            if(ajaxurl == 'undefined' || ajaxurl == null)
                var ajaxurl = "http://www.stereogum.com/wp/wp-admin/admin-ajax.php";
                 
            </script>
 
<script type="text/javascript">
        clarityPageData = {"site_code":"stereogum","zone":"article_page"};
    </script>
<script type="text/javascript">
    (function(){
        window.CLARITY = window.CLARITY || [];
        var ns = document.createElement('script'), s = document.getElementsByTagName('script')[0];
        ns.async = true; ns.type = 'text/javascript'; ns.src = '//lib.pgmcdn.com/clarity-1489097134569.min.js'; s.parentNode.insertBefore(ns, s);
    })();
</script>
<script>var OX_dfp_ads=[['/6419/stereogum/article_page/leaderboard_top',['728x91','970x251','970x91','728x90','970x250','970x90'],'leaderboard_top_1',{"pos":["leaderboard_top"],"pagetype":["article_page"]}],['/6419/stereogum/article_page/leaderboard_bottom_lazy',['728x90','970x250','970x90'],'leaderboard_bottom_lazy_1',{"pos":["leaderboard_bottom_lazy"],"pagetype":["article_page"]}],['/6419/stereogum/article_page/medrec_top',['300x251','300x601','300x250','300x600'],'medrec_top_1',{"pos":["medrec_top"],"pagetype":["article_page"]}],['/6419/stereogum/article_page/medrec_bottom_lazy',['300x250','300x600'],'medrec_bottom_lazy_1',{"pos":["medrec_bottom_lazy"],"pagetype":["article_page"]}],['/6419/stereogum/article_page/leaderboard_bottom_first',['728x90','970x250','970x90'],'leaderboard_bottom_first_1',{"pos":["leaderboard_bottom_first"],"pagetype":["article_page"]}],['/6419/stereogum/article_page/medrec_bottom_first',['300x250','300x600'],'medrec_bottom_first_1',{"pos":["medrec_bottom_first"],"pagetype":["article_page"]}],];</script><script>window.oxDone=function(){CLARITY.push({use:['header','logger'],run:function(header,logger){try{logger.log("Setting OX targeting from template Clarity push","header");header.partners.ox.setTargeting();}catch(e){logger.log("header.oxSetTargeting failed with error : "+e,"error");}}});};(function(){var s=document.createElement('script');s.type='text/javascript';s.async=true;s.src=(document.location.protocol==='https:'?'https:':'http:')+'//spinmedia-d.openx.net/w/1.0/jstag?nc=6419-stereogum';var node=document.getElementsByTagName('script')[0];node.parentNode.appendChild(s);})();CLARITY.push({use:['header'],run:function(header){header.skipJsInject('openx');}});</script>
<script>var rubicon_ads=[['/6419/stereogum/article_page/leaderboard_top',[[728,91],[970,251],[970,91],[728,90],[970,250],[970,90]],'leaderboard_top_1'],['/6419/stereogum/article_page/leaderboard_bottom_lazy',[[728,90],[970,250],[970,90]],'leaderboard_bottom_lazy_1'],['/6419/stereogum/article_page/medrec_top',[[300,251],[300,601],[300,250],[300,600]],'medrec_top_1'],['/6419/stereogum/article_page/medrec_bottom_lazy',[[300,250],[300,600]],'medrec_bottom_lazy_1'],];var rubicontag=rubicontag||{};rubicontag.cmd=rubicontag.cmd||[];(function(){var account_id=11872;var rct=document.createElement('script');rct.type='text/javascript';rct.async=true;rct.src=(document.location.protocol==='https:'?'https:':'http:')+'//ads.rubiconproject.com/header/'+account_id+'.js';var node=document.getElementsByTagName('script')[0];node.parentNode.appendChild(rct);})();CLARITY.push({use:['header'],run:function(header){header.skipJsInject('rubicon');}});</script>
<script>CLARITY.push({use:['header'],run:function(header){header.run({"a9":{"account_id":3125},"openx":{"network_code":"6419-stereogum","positions":{"leaderboard_top":"['728x91','970x251','970x91','728x90','970x250','970x90']","leaderboard_bottom_lazy":"['728x90','970x250','970x90']","medrec_top":"['300x251','300x601','300x250','300x600']","medrec_bottom_lazy":"['300x250','300x600']","leaderboard_bottom_first":"['728x90','970x250','970x90']","medrec_bottom_first":"['300x250','300x600']"}},"rubicon":{"account_id":11872,"positions":{"leaderboard_top":"[[728,91],[970,251],[970,91],[728,90],[970,250],[970,90]]","leaderboard_bottom_lazy":"[[728,90],[970,250],[970,90]]","medrec_top":"[[300,251],[300,601],[300,250],[300,600]]","medrec_bottom_lazy":"[[300,250],[300,600]]"}},"yieldbot":{"desktop":"ws3f","mobile":"sk2l"}});}});</script> <script>
    if("I11C" in window && I11C.Morph == 1){
        window.CLARITY.push({
            use: ["instart"], 
            run: function(instart) { 
                instart.run({
                    'unblocked_ads': ["leaderboard_top","medrec_top","medrec_bottom_lazy"]
                });
            }
        });
        window.CLARITY.push({use: ["ads"],run: function(Ads) { Ads.zone = 'unblocked'; }});
    }
</script><script language="javascript" type="text/javascript" tag="login-settings">
            var show_login = false;        </script>
 
<meta name="description" content="Snoop Dogg inducted Tupac Shakur into the Rock And Roll Hall Of Fame during a ceremony at Brooklyn's Barclays Center last night. &quot;While many remember him now as"/>
<meta name="keywords" content="rock and roll hall of fame,snoop dogg,tupac shakur"/>
<link rel="canonical" href="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/"/>
<meta property="og:title" content="Watch Snoop Dogg Induct Tupac Shakur Into The Rock And Roll Hall Of Fame"/>
<meta property="og:type" content="article"/>
<meta property="og:url" content="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/"/>
<meta property="og:image" content="http://static.stereogum.com/uploads/2017/04/AP_17098330524992-1491662982.jpg"/>
<meta property="og:image:width" content="6000"/>
<meta property="og:image:height" content="4000"/>
<meta property="og:site_name" content="Stereogum"/>
<meta property="og:description" content="Snoop Dogg inducted Tupac Shakur into the Rock And Roll Hall Of Fame during a ceremony at Brooklyn&#039;s Barclays Center last night. &quot;While many remember him now as some kind of thugged out superhero, Tupac really was only good and he represented through his music like no one before,&quot; Snoop began in his speech. &quot;So, while we may be here to celebrate one of music&#039;s most prolific and outspoken artists as he&#039;s rightfully enshrined as one of the greatest musicians to ever do it, I&#039;m here to make sure that Pac is remembered the way he would have wanted to be: a strong black man who stood up. Not somebody who acted like a rapper, but as a human&#8230;That&#039;s what made Tupac the greatest rapper of all time.&quot; Snoop went on to reminisce about his personal experiences with Tupac, including the night that Tupac passed him his first blunt. &quot;That&#039;s right, Tupac is the one that got Snoop Dogg smoking weed,&quot; Snoop said. &quot;I was a zig-zag man before that shit.&quot; Find a transcript of the speech here or watch"/>
<meta property="article:published_time" content="2017-04-08T11:03:14Z"/>
<meta property="article:modified_time" content="2017-04-08T11:24:26Z"/>
<meta name="twitter:card" content="summary"/>
<meta name="twitter:title" content="Watch Snoop Dogg Induct Tupac Shakur Into The Rock And Roll Hall Of Fame"/>
<meta name="twitter:description" content="Snoop Dogg inducted Tupac Shakur into the Rock And Roll Hall Of Fame during a ceremony at Brooklyn&#039;s Barclays Center last night. &quot;While many remember him now as some kind of thugged out superhero, Tupac really was only good and he represented through his music like no one before,&quot; Snoop began in his speech. &quot;So, while we may be here to celebrate one of music&#039;s most prolific and outspoken artists as he&#039;s rightfully enshrined as one of the greatest musicians to ever do it, I&#039;m here to make sure that Pac is remembered the way he would have wanted to be: a strong black man who stood up. Not somebody who acted like a rapper, but as a human&#8230;That&#039;s what made Tupac the greatest rapper of all time.&quot; Snoop went on to reminisce about his personal experiences with Tupac, including the night that Tupac passed him his first blunt. &quot;That&#039;s right, Tupac is the one that got Snoop Dogg smoking weed,&quot; Snoop said. &quot;I was a zig-zag man before that shit.&quot; Find a transcript of the speech here or watch"/>
<meta name="twitter:image" content="http://static.stereogum.com/uploads/2017/04/AP_17098330524992-1491662982-608x405.jpg"/>
<meta itemprop="image" content="http://static.stereogum.com/uploads/2017/04/AP_17098330524992-1491662982-608x405.jpg"/>
 
<link rel='dns-prefetch' href='//assets.stereogum.com'/>
<link rel='dns-prefetch' href='//www.google.com'/>
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="Stereogum &raquo; Watch Snoop Dogg Induct Tupac Shakur Into The Rock And Roll Hall Of Fame Comments Feed" href="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/feed/"/>
<link rel='stylesheet' id='mobile-zoom-css' href='http://assets.stereogum.com/wp-content/plugins/wp-pi-spinmedia-core/css/vendor/mobile-zoom.css?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5' type='text/css' media='all'/>
<link rel='stylesheet' id='pi-gallery-css-css' href='http://assets.stereogum.com/wp-content/plugins/wp-pi-gallery/css/style.css?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5' type='text/css' media='all'/>
<link rel='stylesheet' id='pi-login-css' href='http://assets.stereogum.com/wp-content/plugins/wp-pi-login/css/login.css?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5' type='text/css' media='all'/>
<link rel='stylesheet' id='pi-player-css-css' href='http://assets.stereogum.com/wp-content/plugins/wp-pi-music-player/css/style.css?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5' type='text/css' media='all'/>
<link rel='stylesheet' id='icon-styles-css' href='http://www.stereogum.com/wp-content/themes/wp-theme-base/assets/css/icons.css?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5' type='text/css' media='all'/>
<link rel='stylesheet' id='comment-vote-css' href='http://www.stereogum.com/wp-content/plugins/wp-pi-comment-voting/css/comments.css?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5' type='text/css' media='all'/>
<script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://www.stereogum.com/wp/wp-includes/js/jquery/jquery-migrate.min.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://www.stereogum.com/wp/wp-includes/js/underscore.min.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://assets.stereogum.com/wp-content/plugins/wp-pi-spinmedia-widgets/js/ajax-widgets.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://assets.stereogum.com/wp-content/plugins/wp-pi-spinmedia-core/js/jquery.lazyloadxt.extra.min.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://assets.stereogum.com/wp-content/plugins/wp-pi-spinmedia-core/js/lazyloadxt.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://assets.stereogum.com/wp-content/plugins/wp-pi-spinmedia-core/js/lazyoEmbeds.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<link rel='https://api.w.org/' href='http://www.stereogum.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.stereogum.com/wp/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.stereogum.com/wp/wp-includes/wlwmanifest.xml"/>
<link rel='prev' title='Frank Ocean &#8211; &#8220;Biking&#8221; (Feat. Jay Z &#038; Tyler, The Creator)' href='http://www.stereogum.com/1934125/frank-ocean-biking-feat-jay-z-tyler-the-creator/music/'/>
<link rel='next' title='Watch Alicia Keys, Snoop Dogg, YG, T.I. &#038; More Perform Tupac Tribute At Rock Hall Ceremony' href='http://www.stereogum.com/1934134/watch-alicia-keys-snoop-dogg-yg-t-i-more-perform-tupac-tribute-at-rock-hall-ceremony/video/'/>
<meta name="generator" content="WordPress 4.7.3"/>
<link rel='shortlink' href='http://www.stereogum.com/?p=1934129'/>
<link rel="alternate" type="application/json+oembed" href="http://www.stereogum.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.stereogum.com%2F1934129%2Fwatch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame%2Fnews%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://www.stereogum.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.stereogum.com%2F1934129%2Fwatch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame%2Fnews%2F&#038;format=xml"/>
<meta property="fb:pages" content="13472576978"/><script>
    var ajax_url = 'http\x3A\x2F\x2Fwww.stereogum.com\x2Fajax';
</script><link rel="amphtml" href="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news?amp=1"/>
<link href='http://fonts.googleapis.com/css?family=Asap:400,700,400italic,700italic|Montserrat:400,700' rel='stylesheet' type='text/css'>
</head>
<body itemscope itemtype="http://schema.org/Article" class="post-template-default single single-post postid-1934129 single-format-image">
 
<noscript>
<iframe src="//www.googletagmanager.com/ns.html?id=GTM-TSGWDG" height="0" width="0" style="display:none;visibility:hidden"></iframe>
</noscript>
<script>
                dataLayer = [{"post id":1934129,"pagetype":"article-page","author":"Peter Helman","category":"news","published date":"2017040811","parent tag":"none","tags":"Rock And Roll Hall Of Fame, Snoop Dogg, Tupac Shakur"}];
                                (function (w, d, s, l, i) {
                    w[l] = w[l] || [];
                    w[l].push({
                        'gtm.start': new Date().getTime(), event: 'gtm.js'
                    });
                    var f = d.getElementsByTagName(s)[0],
                        j = d.createElement(s), dl = l != 'dataLayer' ? '&l=' + l : '';
                    j.async = true;
                    j.src =
                        '//www.googletagmanager.com/gtm.js?id=' + i + dl + '';
                    f.parentNode.insertBefore(j, f);
                })(window, document, 'script', 'dataLayer', 'GTM-TSGWDG');</script>
 
<div id="menu" class="navbar navbar-default navbar-fixed-top " role="navigation">
<div class="container">
<div class="inner-nav-holder">
<div class="navbar-header">
<a href="/" class="navbar-brand" id="logo">
<img src="http://assets.stereogum.com/wp-content/themes/stereogum/assets/images/logo.svg" width="224" height="20"/>
</a>
</div>
<div class="collapse navbar-collapse">
<ul class="main-nav nav navbar-nav">
<li class="dropdown dropdown-hover   menu-item-has-children">
<a href="/features" class="dropdown-toggle">
Features
<span class="caret"></span>
</a>
<div class="dropdown-menu"> <div class="menu-holder" role="menu">
<div class="menu-column">
<div class="menu-item">
<a href="http://www.stereogum.com/category/franchises/10-best-songs/">
<span>
10 Best Songs
</span>
</a>
</div>
<div class="menu-item">
<a href="http://www.stereogum.com/category/franchises/album-of-the-week/">
<span>
Album Of The Week
</span>
</a>
</div>
<div class="menu-item">
<a href="http://www.stereogum.com/category/franchises/band-to-watch/">
<span>
Band To Watch
</span>
</a>
</div>
<div class="menu-item">
<a href="http://www.stereogum.com/category/franchises/best-covers/">
<span>
Best Covers
</span>
</a>
</div>
<div class="menu-item">
<a href="http://www.stereogum.com/category/franchises/but-whos-buying/">
<span>
But Who's Buying?
</span>
</a>
</div>
<div class="menu-item">
<a href="http://www.stereogum.com/category/franchises/cover-story/">
<span>
Cover Story
</span>
</a>
</div>
<div class="menu-item">
<a href="http://www.stereogum.com/category/franchises/counting-down/">
<span>
Counting Down
</span>
</a>
</div>
</div>
<div class="menu-column">
<div class="menu-item">
<a href="http://www.stereogum.com/category/franchises/interview/">
<span>
Interview
</span>
</a>
</div>
<div class="menu-item">
<a href="http://www.stereogum.com/category/franchises/premature-evaluation/">
<span>
Premature Evaluation
</span>
</a>
</div>
<div class="menu-item">
<a href="http://www.stereogum.com/category/shut-up-dude/">
<span>
Shut Up Dude
</span>
</a>
</div>
<div class="menu-item">
<a href="http://www.stereogum.com/category/franchises/sounding-board/">
<span>
Sounding Board
</span>
</a>
</div>
<div class="menu-item">
<a href="http://www.stereogum.com/category/franchises/status-aint-hood/">
<span>
Status Ain't Hood
</span>
</a>
</div>
<div class="menu-item">
<a href="http://www.stereogum.com/category/franchises/straight-to-video/">
<span>
Straight To Video
</span>
</a>
</div>
<div class="menu-item">
<a href="http://www.stereogum.com/category/franchises/the-5-best-songs-of-the-week/">
<span>
The 5 Best Songs Of The Week
</span>
</a>
</div>
</div>
<div class="menu-column">
<div class="menu-item">
<a href="http://www.stereogum.com/category/franchises/the-anniversary/">
<span>
The Anniversary
</span>
</a>
</div>
<div class="menu-item">
<a href="http://www.stereogum.com/category/franchises/the-black-market/">
<span>
The Black Market
</span>
</a>
</div>
<div class="menu-item">
<a href="http://www.stereogum.com/category/franchises/the-week-in-pop/">
<span>
The Week In Pop
</span>
</a>
</div>
<div class="menu-item">
<a href="http://www.stereogum.com/category/franchises/ultimate-playlist/">
<span>
Ultimate Playlist
</span>
</a>
</div>
<div class="menu-item">
<a href="http://www.stereogum.com/category/wheres-the-beef/">
<span>
Where's The Beef?
</span>
</a>
</div>
<div class="feature-link menu-item">
<a href="http://www.stereogum.com/category/franchises/">
<span>
All Features
</span>
</a>
</div>
</div>
</div>
<div class="featured-nav">
<span class="the-latest">the latest //</span>
<span class="franchise-title">The 5 Best Songs Of The Week</span>
<a href="http://www.stereogum.com/1933995/the-5-best-songs-of-the-week-186/franchises/the-5-best-songs-of-the-week/">
<span>
<img src="http://static.stereogum.com/uploads/2017/04/the-5-best-songs-of-the-week-dark-1491576571-231x154.jpg" alt="The 5 Best Songs Of The Week">
</span>
</a>
<div class="feat-title"><a href="http://www.stereogum.com/1933995/the-5-best-songs-of-the-week-186/franchises/the-5-best-songs-of-the-week/">The 5 Best Songs Of The Week</a></div>
</div>
</div>
</li>
<li class="  ">
<a href="/music">
Songs
</a>
</li>
<li class="  ">
<a href="/video">
Videos
</a>
</li>
<li class="  ">
<a href="http://www.stereogum.com/category/franchises/list/">
Lists
</a>
</li>
</ul>
<div class="social-and-search">
<ul class="social-links">
<li>
<a class="icon-facebook" href="http://www.facebook.com/Stereogum" target="_blank"></a>
</li>
<li>
<a class="icon-twitter" href="http://www.twitter.com/stereogum" target="_blank"></a>
</li>
<li class="more-social-icons">
<span class="icon-plus"></span>
<ul class="extra-4">
<li>
<a class="icon-instagram" href="http://www.instagram.com/stereogum" target="_blank"></a>
</li>
<li>
<a class="icon-tumblr" href="http://stereogum.tumblr.com" target="_blank"></a>
</li>
<li>
<a class="icon-spotify" href="https://open.spotify.com/user/stereogum" target="_blank"></a>
</li>
<li>
<a class="icon-youtube" href="https://www.youtube.com/stereogum" target="_blank"></a>
</li>
</ul>
</li>
</ul>
<div class="search">
<form role="search" action="/" method="GET" id="header-search">
<div class="query-holder">
<input type="text" name="s" placeholder="Search" autocomplete="off">
</div>
<span class="search-submit"></span>
</form>
</div>
<div class="user-profile">
<a href="" title="Your Profile">
<span class="icon-user"></span>
</a>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="social-holder sticky-header">
<div class="social-icons">
<div class="social-container">
<div class="logo"><a href="/"></a></div>
<div class="title">Share < br />this article:</div>
<div class="email sharrre" data-url="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/" data-short-url="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/" data-utm-source="share-email" data-text="Watch Snoop Dogg Induct Tupac Shakur Into The Rock And Roll Hall Of Fame" data-title="Email"></div>
<div class="facebook sharrre" data-url="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/" data-short-url="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/" data-utm-source="share-fb" data-text="Watch Snoop Dogg Induct Tupac Shakur Into The Rock And Roll Hall Of Fame" data-title="Share"></div>
<div class="twitter sharrre" data-url="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/" data-short-url="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/" data-utm-source="share-tw" data-text="Watch Snoop Dogg Induct Tupac Shakur Into The Rock And Roll Hall Of Fame" data-title="Tweet"></div>
<div class="pinterest sharrre" data-url="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/" data-short-url="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/" data-utm-source="share-pnt" data-text="Watch Snoop Dogg Induct Tupac Shakur Into The Rock And Roll Hall Of Fame" data-title="Pin It" data-media="http://static.stereogum.com/uploads/2017/04/AP_17098330524992-1491662982.jpg"></div>
<div class="reddit sharrre" data-url="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/" data-short-url="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/" data-utm-source="share-red" data-text="Watch Snoop Dogg Induct Tupac Shakur Into The Rock And Roll Hall Of Fame" data-title="Reddit"></div>
</div>
</div> </div>
<div class="container ad-container">
<div class="leaderboard_top-placeholder">
<div class="leaderboard_top-holder">
<div class="leaderboard-wrapper">
<div class="ad_desktop_placeholder">
<div class="ad_desktop_wrapper">
<div class="ad_desktop leaderboard" data-position='leaderboard_top' data-sizes='[[728,91],[970,251],[970,91],[728,90],[970,250],[970,90]]' data-lazy-load='0' data-refresh='0' data-refresh-timer='0' data-swap='' data-load-order='1' style="min-width: 728px; min-height: 90px; box-sizing: content-box;">
</div>
</div>
</div>
</div>
</div>
</div> </div>
<div class="container main-container">
<div class="row">
<div class="col-sm-8 left-col">
<div class="article-body" itemScope itemType="https://schema.org/Article">
<div>
<h1 itemprop="name">
<a href="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/">Watch Snoop Dogg Induct Tupac Shakur Into The Rock And Roll Hall Of Fame</a>
</h1>
</div>
<div itemprop="author" itemscope itemtype="http://schema.org/Person" class="author">
<a href="http://www.stereogum.com/author/peter-helman/">Peter Helman</a>
<span class="twitter">
<a href="//twitter.com/_peterhelman" class="twitter-handle" target="blank">@_peterhelman</a>
</span>
<span class="date">| April 8, 2017 - 11:03 am</span>
</div>
<div class="social-holder">
<div class="social-icons post-header">
<div class="social-container">
<div class="logo"><a href="/"></a></div>
<div class="title">Share < br />this article:</div>
<div class="email sharrre" data-url="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/" data-short-url="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/" data-utm-source="share-email" data-text="Watch Snoop Dogg Induct Tupac Shakur Into The Rock And Roll Hall Of Fame" data-title="Email"></div>
<div class="facebook sharrre" data-url="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/" data-short-url="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/" data-utm-source="share-fb" data-text="Watch Snoop Dogg Induct Tupac Shakur Into The Rock And Roll Hall Of Fame" data-title="Share"></div>
<div class="twitter sharrre" data-url="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/" data-short-url="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/" data-utm-source="share-tw" data-text="Watch Snoop Dogg Induct Tupac Shakur Into The Rock And Roll Hall Of Fame" data-title="Tweet"></div>
<div class="pinterest sharrre" data-url="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/" data-short-url="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/" data-utm-source="share-pnt" data-text="Watch Snoop Dogg Induct Tupac Shakur Into The Rock And Roll Hall Of Fame" data-title="Pin It" data-media="http://static.stereogum.com/uploads/2017/04/AP_17098330524992-1491662982.jpg"></div>
<div class="reddit sharrre" data-url="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/" data-short-url="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/" data-utm-source="share-red" data-text="Watch Snoop Dogg Induct Tupac Shakur Into The Rock And Roll Hall Of Fame" data-title="Reddit"></div>
</div>
</div> </div>
<div class="featured-embed-holder format-image">
<div class="article-image-holder">
<div itemscope itemtype="http://schema.org/ImageObject" class="mainembed photoembed mainembed-article-embed/large align-center">
<div class="img-wrap">
<img class="imageresource zoom-image" itemprop="image" src="http://static.stereogum.com/uploads/2017/04/AP_17098330524992-1491662982-640x427.jpg" data-img-zoom="http://static.stereogum.com/uploads/2017/04/AP_17098330524992-1491662982-compressed.jpg" data-img-zoom-w="6000" data-img-zoom-h="4000" alt="Snoop Dogg" width="640" height="427">
</div>
<div class="credit-wrapper">
<div class="credit"><small>CREDIT:</small> Charles Sykes/Invision/AP</div>
</div>
</div>
</div>
</div>
<div class="article-content-holder">
<div itemprop="articleBody" class="single-content-holder">
<div class="article-content clearfix" itemprop="articleBody">
<p>Snoop Dogg inducted Tupac Shakur into the Rock And Roll Hall Of Fame during a ceremony at Brooklyn&#8217;s Barclays Center last night. &#8220;While many remember him now as some kind of thugged out superhero, Tupac really was only good and he represented through his music like no one before,&#8221; Snoop began in his speech. &#8220;So, while we may be here to celebrate one of music&#8217;s most prolific and outspoken artists as he&#8217;s rightfully enshrined as one of the greatest musicians to ever do it, I&#8217;m here to make sure that Pac is remembered the way he would have wanted to be: a strong black man who stood up. Not somebody who acted like a rapper, but as a human&#8230;That&#8217;s what made Tupac the greatest rapper of all time.&#8221; Snoop went on to reminisce about his personal experiences with Tupac, including the night that Tupac passed him his first blunt. &#8220;That&#8217;s right, Tupac is the one that got Snoop Dogg smoking weed,&#8221; Snoop said. &#8220;I was a zig-zag man before that shit.&#8221; Find a transcript of the speech <a href="http://www.rollingstone.com/music/news/read-snoop-doggs-emotional-rock-hall-speech-inducting-tupac-w475816" target="_blank">here</a> or watch below. </p>
<div class="oembed"><iframe width="600" height="450" data-src="https://www.youtube.com/embed/TVzbapajkbI?feature=oembed" frameborder="0" allowfullscreen class="lazy-hidden"></iframe></div>
<p>After the induction, Snoop Dogg <a href="http://www.stereogum.com/1934134/watch-alicia-keys-snoop-dogg-yg-t-i-more-perform-tupac-tribute-at-rock-hall-ceremony/video/">performed a tribute</a> to Tupac with Alicia Keys, YG, and T.I.</p>
</div>
</div>
<div class="row tags-and-comments">
<div class="col-sm-9">
<div itemprop="keywords" class="tags">
<strong>Tags:</strong>
<a href="http://www.stereogum.com/tag/rock-and-roll-hall-of-fame/">Rock And Roll Hall Of Fame</a>, <a href="http://www.stereogum.com/tag/snoop-dogg/">Snoop Dogg</a>, <a href="http://www.stereogum.com/tag/tupac-shakur/">Tupac Shakur</a> </div>
</div>
<div class="col-sm-3">
<div class="comments right">
<a href="#comments" class="comments-bubble"></a>
</div>
</div>
</div>
</div>
</div>
<hr>
<div class="zergnet-holder">
<div class="zergnet-widget" id="zergnet-widget-33148"></div>
<script language="javascript" type="text/javascript">
        (function () {
            var zergnet = document.createElement('script');
            zergnet.type = 'text/javascript';
            zergnet.async = true;
            zergnet.src = 'http://www.zergnet.com/zerg.js?id=33148';
            var znscr = document.getElementsByTagName('script')[0];
            znscr.parentNode.insertBefore(zergnet, znscr);

            zergnet.onload = function(){ 
                window.dataLayer = window.dataLayer || [];
                var zergnetId = '33148';

                if(zergnetId) {
                    window.dataLayer.push({
                        'event': 'zergnet',
                        'action': 'loaded',
                        'label': zergnetId
                    }); 
                }
            };
        })();
    </script>
</div>
<div class="link-exchanges">
<div class="recommended-module ">
<div class="title-holder">
<h2>Recommended for you</h2>
</div>
<div class="row">
</div>
<div class="row">
<div class="col-sm-4">
<div class="image-holder">
<a href="http://www.stereogum.com/1934157/yes-rick-wakeman-roasts-his-family-and-describes-his-prostate-exam-in-rock-hall-induction-speech/video/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="1">
<img src="http://static.stereogum.com/uploads/2017/04/GettyImages-665961292-1491671622-191x127.jpg" width="191" height="127" alt="Yes&#8217; Rick Wakeman Roasts His Family And Describes His Prostate Exam In Rock Hall Induction Speech">
</a>
</div>
<div class="preview-holder">
<a href="http://www.stereogum.com/1934157/yes-rick-wakeman-roasts-his-family-and-describes-his-prostate-exam-in-rock-hall-induction-speech/video/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="1">
<h3>
Yes&#8217; Rick Wakeman Roasts His Family And Describes His Prostate Exam In Rock Hall Induction Speech
</h3>
</a>
</div>
</div>
<div class="col-sm-4">
<div class="image-holder">
<a href="http://www.stereogum.com/1934143/watch-david-letterman-induct-pearl-jam-into-the-rock-roll-hall-of-fame/video/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="2">
<img src="http://static.stereogum.com/uploads/2017/04/GettyImages-665999458-1491669156-191x127.jpg" width="191" height="127" alt="Watch David Letterman Induct Pearl Jam Into The Rock &#038; Roll Hall Of Fame">
</a>
</div>
<div class="preview-holder">
<a href="http://www.stereogum.com/1934143/watch-david-letterman-induct-pearl-jam-into-the-rock-roll-hall-of-fame/video/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="2">
<h3>
Watch David Letterman Induct Pearl Jam Into The Rock &#038; Roll Hall Of Fame
</h3>
</a>
</div>
</div>
<div class="col-sm-4">
<div class="image-holder">
<a href="http://www.stereogum.com/1934139/watch-pearl-jam-rush-journey-more-cover-neil-youngs-rockin-in-the-free-world-at-rock-hall-ceremony/video/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="3">
<img src="http://static.stereogum.com/uploads/2017/04/AP_17098153565348-1491666819-191x127.jpg" width="191" height="127" alt="Watch Pearl Jam, Rush, Journey, &#038; More Cover Neil Young&#8217;s &#8220;Rockin&#8217; In The Free World&#8221; At Rock Hall Ceremony">
</a>
</div>
<div class="preview-holder">
<a href="http://www.stereogum.com/1934139/watch-pearl-jam-rush-journey-more-cover-neil-youngs-rockin-in-the-free-world-at-rock-hall-ceremony/video/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="3">
<h3>
Watch Pearl Jam, Rush, Journey, &#038; More Cover Neil Young&#8217;s &#8220;Rockin&#8217; In The Free World&#8221; At Rock Hall Ceremony
</h3>
</a>
</div>
</div>
</div>
<div class="row">
<div class="col-sm-4">
<div class="image-holder">
<a href="http://www.stereogum.com/1934134/watch-alicia-keys-snoop-dogg-yg-t-i-more-perform-tupac-tribute-at-rock-hall-ceremony/video/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="4">
<img src="http://static.stereogum.com/uploads/2017/04/AP_17098332181724-1491664873-191x127.jpg" width="191" height="127" alt="Watch Alicia Keys, Snoop Dogg, YG, T.I. &#038; More Perform Tupac Tribute At Rock Hall Ceremony">
</a>
</div>
<div class="preview-holder">
<a href="http://www.stereogum.com/1934134/watch-alicia-keys-snoop-dogg-yg-t-i-more-perform-tupac-tribute-at-rock-hall-ceremony/video/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="4">
<h3>
Watch Alicia Keys, Snoop Dogg, YG, T.I. &#038; More Perform Tupac Tribute At Rock Hall Ceremony
</h3>
</a>
</div>
</div>
<div class="col-sm-4">
<div class="image-holder">
<a href="http://www.stereogum.com/1934045/steve-perry-will-perform-with-journey-for-the-first-time-in-over-25-years-at-rock-hall-induction-tonight/news/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="5">
<img src="http://static.stereogum.com/uploads/2017/04/Untitled-1491585042-191x127.png" width="191" height="127" alt="Steve Perry Will Perform With Journey For The First Time In Over 25 Years At Rock Hall Induction Tonight (UPDATE: Not)">
</a>
</div>
<div class="preview-holder">
<a href="http://www.stereogum.com/1934045/steve-perry-will-perform-with-journey-for-the-first-time-in-over-25-years-at-rock-hall-induction-tonight/news/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="5">
<h3>
Steve Perry Will Perform With Journey For The First Time In Over 25 Years At Rock Hall Induction Tonight (UPDATE: Not)
</h3>
</a>
</div>
</div>
<div class="col-sm-4">
<div class="image-holder">
<a href="http://www.stereogum.com/1933575/david-letterman-to-induct-pearl-jam-into-rock-and-roll-hall-of-fame/news/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="6">
<img src="http://static.stereogum.com/uploads/2017/04/Pearl-Jam-and-David-Letterman-1491403911-191x127.jpg" width="191" height="127" alt="David Letterman To Induct Pearl Jam Into Rock And Roll Hall Of Fame">
</a>
</div>
<div class="preview-holder">
<a href="http://www.stereogum.com/1933575/david-letterman-to-induct-pearl-jam-into-rock-and-roll-hall-of-fame/news/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="6">
<h3>
David Letterman To Induct Pearl Jam Into Rock And Roll Hall Of Fame
</h3>
</a>
</div>
</div>
</div>
</div>
</div>
<div id="amazon-widget"></div>
<script type="text/javascript">
                        amzn_assoc_tracking_id = "stereogum0b-20";
                    </script>
<script type="text/javascript" src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&source=ac"></script>
<script type="text/template" id="newCommentFormTemplate_LoggedIn"><div id="post-comment-form"><div class="comment-textarea"><p class="form-textarea"><label for="comment" class="post-comment-label"></label><textarea name="comment" id="new-comment-textarea" tabindex="1" placeholder="Leave a comment..."></textarea></p></div><div class="comment-action-row"><div class="form-username">
                    Logged in as <b><%= currentUsername %></b>. <a class="logout-link" href="<%= ajax_comments_vars.signout_link %>">Log out</a></div><div class="form-submit"><span class="comments-help-button"></span><button id="submit-new-comment-button" tabindex="4">Submit</button></div><div class="form-errors closed" id="new-comment-errors"></div><div class="cleaner"></div></div></div></script><script type="text/template" id="newCommentFormTemplate_LoggedInGuest"><div id="post-comment-form"><div class="comment-textarea"><p class="form-textarea"><label for="comment" class="post-comment-label"></label><textarea name="comment" id="new-comment-textarea" tabindex="1" placeholder="Leave a comment..."></textarea></p></div><div class="comment-action-row"><div class="comment-guest-form form-inline"><div class="form-group"><label class="sr-only" for="author">Name (required and visible)</label><input type="text" class="text-input" name="author" id="author" tabindex="1" value="" placeholder="Name (required and visible)"></div><div class="form-group"><label class="sr-only" for="email">Email (required, but not visible)</label><input type="email" class="text-input" name="email" name="email" id="email" tabindex="2" value="" size="40" placeholder="Email (required, but not visible)" /></div><div class="form-submit"><span class="comments-help-button"></span><button id="submit-new-guest-comment-button" tabindex="3">Submit</button></div><div class="form-errors closed" id="new-comment-errors"></div></div><% if (ajax_comments_vars.commentLogin) { %><div class="form-username">
                    Commenting as a guest. Or, you can <a href="#" class="sign-in-link">log in</a>.
                </div><% } %></div></div></script><script type="text/template" id="newCommentFormTemplate_LoggedOut"><div id="post-comment-form"><div class="comment-textarea"><p class="form-textarea"><label for="comment" class="post-comment-label"></label><textarea name="comment" id="new-comment-textarea" tabindex="1" placeholder="Leave a comment..."></textarea></p></div><div class="comment-action-row"><div class="form-username"><p>You must be logged in to post a comment.</p><p><a href="#" class="sign-in-link">Click here to log in.</a></p></div><div class="cleaner"></div></div></div></script><script type="text/template" id="replyCommentFormTemplate_LoggedIn"><div class="comment-reply-form closed"><form action="<%= ajax_comments_vars.siteurl %>/wp-comments-post.php" method="post" id="commentform" class="standard-form"><p class="form-textarea"><label for="comment"></label><textarea name="comment" id="comment" cols="40" rows="5" placeholder="Reply to <%= comment.comment_author %>..."></textarea></p></form><div class="reply-actions buttons"><span class="comments-help-button"></span><button class="cancel-button" type="button">Cancel</button><button class="reply-submit-button" id="reply-submit-<%= comment.comment_ID %>" type="button">Submit</button></div><div class="reply-errors closed"></div></div></script><script type="text/template" id="replyCommentFormTemplate_LoggedInGuest"><div class="comment-reply-form closed"><div class="reply-username"><span class="reply-username"><% if (ajax_comments_vars.commentLogin) { %>
                    Replying to <%= comment.comment_author %> as a guest. Or, you can <a href="#" class="sign-in-link"> log in</a>.
                    <% } else { %>
                    Replying to <%= comment.comment_author %>.
                    <% } %></span></div><div class="reply-inputs"><form action="<%= ajax_comments_vars.siteurl %>/wp-comments-post.php" method="post" id="commentform" class="standard-form"><div class="form-textarea"><div class="form-group"><label for="comment" class="comment-label-off"></label><textarea name="comment" id="comment" class="reply-textfield" cols="40" rows="5" placeholder="Reply to <%= comment.comment_author %>..."></textarea></div></div><div class="form-inline"><div class="form-group pull-left"><label class="sr-only" for="author">Name (required and visible)</label><input type="text" class="form-control text-input" name="author" id="author" value="" placeholder="Name (required and visible)"></div><div class="form-group pull-right"><label class="sr-only" for="email">Email (required, but not visible)</label><input type="email" class="form-control text-input" name="email" name="email" id="email" value="" placeholder="Email (required, but not visible)"></div></div></form></div><div class="reply-actions buttons"><span class="comments-help-button"></span><button class="cancel-button" type="button">Cancel</button><button class="reply-guest-submit-button" id="reply-submit-<%= comment.comment_ID %>" type="button">Submit</button></div><div class="reply-errors closed"></div></div></script><script type="text/template" id="replyCommentFormTemplate_LoggedOut"><div class="comment-reply-form closed">
            You must be logged in to reply. <a href="#" class="sign-in-link">Click here to log in.</a></div></script><div id="comments"><div class="commentHead"><span id="main-comment-count"><a href="http://www.stereogum.com/1934129/watch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame/news/#respond">Comments</a></span><div class="dotBorder"></div><div class="cleaner"></div></div><div id="loader"><img src="http://www.stereogum.com/wp-content/plugins/wp-pi-comments/images/loader.svg"></div><button id="show-all-comments">Show the rest of the comments</button><ol class="commentlist-ice noavas"></ol> <div id="comments-navigation-buttons"><div class="buttons"><div class="floats"><button id="comments-scroll-to-top"><span class="icon icon-chevron-left"></span></button><button id="comments-scroll-to-bottom"><span class="icon icon-chevron-right"></span></button></div></div></div><a id="bottom-of-comments"></a></div><div id="after-comments"></div><div class="comment-action"><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="6bdfe7a2ec"/></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="122"/></p></div><input type='hidden' name='comment_post_ID' value='1934129' id='comment_post_ID'/><input type='hidden' name='comment_parent' id='comment_parent' value='0'/><script type="text/template" id="commentTemplate"><li id="comment-<%= comment.comment_ID %>"<% if (isNewParent) { %> class="new-parent-comment" <% } %><% if (comment.attachment_post_ID && comment.comment_parent == 0) { %>attachment="<%= comment.attachment_post_ID %>"<% } %>><div class="comment-content <% if (isNewParent) { %>new-parent<% } %>"><% if (ajax_comments_vars.isMobile) { %><% if (comment.avatar_url) { %><div class="comment-avatar-box"><div class="avb"><% if (comment.comment_author_URL) { %><a href="<%= comment.comment_author_URL %>" rel="nofollow"><div class="avatar-box-50"><%= comment.avatar_url %></div></a><% } else { %><div class="avatar-box-50"><%= comment.avatar_url %></div><% } %></div></div><% } %><% } %><div class="comment-name-and-text"><% if (!ajax_comments_vars.isMobile) { %><% if (comment.avatar_url) { %><div class="comment-avatar-box"><div class="avb"><% if (comment.comment_author_URL) { %><a href="<%= comment.comment_author_URL %>" rel="nofollow"><div class="avatar-box-50"><%= comment.avatar_url %></div></a><% } else { %><div class="avatar-box-50"><%= comment.avatar_url %></div><% } %></div></div><% } %><% } %><% if (comment.attachment_img && comment.comment_parent == 0) { %><div class="commented-on-photo"><a href="<%= comment.attachment_post_link %>"><img src="<%= comment.attachment_img %>" width="60" height="60"></a></div><% } %><div class="comment-meta"><span class="comment-author-username"><% if (comment.comment_author_URL) { %><a href="<%= comment.comment_author_URL %>"><%= comment.comment_author %></a><% } else { %><%= comment.comment_author %><% } %></span><span class="reply-username"><% if (repliedToUser != false) { %> (in reply to <%= repliedToUser %>)<% } %><span class="reply-username"></div><% if (comment.downvoted) { %><div class="comment-text"><p>
                            This comment is hidden as it has many downvotes. <a href="" class="unhide-downvoted-comment">Click here to show it.</a></p></div><div class="comment-text downvoted"><% } else { %><div class="comment-text"><% } %><%= comment.comment_content %></div></div><div class="comment-options"><div class="comment-info-and-votes"><span class="date"><a href="#comment-<%= comment.comment_ID %>"><%= comment.comment_date %></a></span><%= comment.voting_div.buttons %><span class="comment-score" title="<%= comment.voting_div.ratio %><% if (comment.voting_div.userVoted) { %> You already voted for this comment.<% } %>"><%= comment.voting_div.sum %></span></div><div class="buttons"><% if (comment.edit_link) { %><a href="<%= comment.edit_link %>"><button class="edit-button">Edit</button></a><% } %><button class="reply-button" id="reply-<%= comment.comment_ID %>">Reply</button></div></div></div><ul class="children"></ul></li></script>
</div>
<div class="col-sm-4 sidebar">
<div class="sm-widget sm-widget-ad-holder"><div class="sm-widget-ad"> <div class="ad_desktop" data-position='medrec_top' data-sizes='[[300,251],[300,601],[300,250],[300,600]]' data-lazy-load='0' data-refresh='0' data-refresh-timer='0' data-swap='' data-load-order='2' style="min-width: 300px; min-height: 250px; box-sizing: content-box;">
</div>
</div></div><div class="sidebar-module ajax-widget" data-widget-id="spinmedia_widgets_widgetsaggregator-10"></div><div class="sidebar-mobule sm-widget sm-widget-campaign-monitor">
<div class="widget-head">
<h3>Stereogum Digest</h3>
</div>
<div class="widget-content">
<div class="success hidden">
Thank you for signing up for our newsletter. You will receive a confirmation shortly.
</div>
<form action="http://spinmedia1.createsend.com/t/i/s/jtjllh/" method="post" class="cm-form">
<input id="fieldEmail" name="cm-jtjllh-jtjllh" type="email" required placeholder="Enter your email"/>
<button type="submit" name="cm_submit">Sign Up</button>
<div class="error" class="hidden">
</div>
</form>
</div>
</div>
<div id="text-4" class="widget_text"><h3 class="title">Play The &#8216;Gum Mix</h3> <div class="textwidget"><div class="play-the-gum-mix"><a href="#" onclick="window.open('http://www.stereogum.com/player/the-gum-mix/', 'gumMix', 'toolbar=no,location=no,status=no,menubar=no,scrollbars=yes,resizable=yes,width=810,height=855');return false;">Play the Gum Mix <span class="icon-play-arrow"></span></a></div></div>
</div><div class="sidebar-module record">
<div class="feed feed-tile"><div class="title-holder clearfix"><div class="title left"><a href="/heavy-rotation"><h2>
Heavy Rotation
</h2></a></div><div class="see-all right"><a href="/heavy-rotation">All »</a></div></div><div class="posts clearfix"><div class="post"><div class="image-holder"><a href="/tag/future-islands"><img src="http://static.stereogum.com/uploads/2017/04/Future-Islands-The-Far-Field-1491320252-146x146.jpeg" width="146" height="146" alt="Future Islands &#8211; The Far Field"></a></div><div class="preview-holder"><a href="/tag/future-islands"><span>Future Islands &#8211; The Far Field</span></a></div></div><div class="post"><div class="image-holder"><a href="/tag/father-john-misty"><img src="http://static.stereogum.com/uploads/2017/03/Father-John-Misty-Pure-Comedy-1490972808-146x146.jpg" width="146" height="146" alt="Father John Misty &#8211; Pure Comedy"></a></div><div class="preview-holder"><a href="/tag/father-john-misty"><span>Father John Misty &#8211; Pure Comedy</span></a></div></div></div><div class="posts clearfix"><div class="post"><div class="image-holder"><a href="/tag/kodak-black"><img src="http://static.stereogum.com/uploads/2017/03/Kodak-Black-Painting-Pictures-1490971744-146x146.jpg" width="146" height="146" alt="Kodak Black &#8211; Painting Pictures"></a></div><div class="preview-holder"><a href="/tag/kodak-black"><span>Kodak Black &#8211; Painting Pictures</span></a></div></div><div class="post"><div class="image-holder"><a href="/tag/freddie-gibbs"><img src="http://static.stereogum.com/uploads/2017/03/Freddie-Gibbs-You-Only-Live-2wice-1490969806-146x146.jpg" width="146" height="146" alt="Freddie Gibbs &#8211; You Only Live 2wice"></a></div><div class="preview-holder"><a href="/tag/freddie-gibbs"><span>Freddie Gibbs &#8211; You Only Live 2wice</span></a></div></div></div><div class="posts clearfix"><div class="post"><div class="image-holder"><a href="/tag/show-me-the-body"><img src="http://static.stereogum.com/uploads/2017/03/Show-Me-The-Body-1489412688-640x6401-1490324452-640x6401-1490887949-146x146.jpg" width="146" height="146" alt="Show Me The Body &#8211; Corpus I"></a></div><div class="preview-holder"><a href="/tag/show-me-the-body"><span>Show Me The Body &#8211; Corpus I</span></a></div></div><div class="post"><div class="image-holder"><a href="/tag/pharmakon"><img src="http://static.stereogum.com/uploads/2017/03/phcontact-1490887034-146x146.jpg" width="146" height="146" alt="Pharmakon &#8211; Contact"></a></div><div class="preview-holder"><a href="/tag/pharmakon"><span>Pharmakon &#8211; Contact</span></a></div></div></div><div class="posts clearfix"><div class="post"><div class="image-holder"><a href="/tag/aimee-mann"><img src="http://static.stereogum.com/uploads/2017/03/Aimee-Mann-1490709906-146x146.png" width="146" height="146" alt="Aimee Mann &#8211; Mental Illness"></a></div><div class="preview-holder"><a href="/tag/aimee-mann"><span>Aimee Mann &#8211; Mental Illness</span></a></div></div><div class="post"><div class="image-holder"><a href="/tag/christian-scott"><img src="http://static.stereogum.com/uploads/2017/03/christian-scott-rebel-ruler-1490638651-146x146.jpg" width="146" height="146" alt="Christian Scott &#8211; Ruler Rebel"></a></div><div class="preview-holder"><a href="/tag/christian-scott"><span>Christian Scott &#8211; Ruler Rebel</span></a></div></div></div></div> </div><div class="sm-widget sm-widget-ad-holder"><div class="sm-widget-ad"> <div class="ad_desktop" data-position='medrec_bottom_lazy' data-sizes='[[300,250],[300,600]]' data-lazy-load='1' data-refresh='1' data-refresh-timer='15' data-swap='' data-load-order='' style="min-width: 300px; min-height: 250px; box-sizing: content-box;">
</div>
</div></div>
</div>
</div>
</div>
<div class="container footer-ad-holder">
<div class="leaderboard-wrapper">
<div class="ad_desktop leaderboard" data-position='leaderboard_bottom_lazy' data-sizes='[[728,90],[970,250],[970,90]]' data-lazy-load='1' data-refresh='0' data-refresh-timer='0' data-swap='' data-load-order='' style="min-width: 728px; min-height: 90px; box-sizing: content-box;">
</div>
</div>
</div>
<div class="footer-recommended">
<div class="container">
<h3>
In Case You Missed It </h3>
<div class="row">
<a href="http://www.stereogum.com/1711293/30-essential-post-rock-songs/franchises/ultimate-playlist/">
<div class="post col-sm-4">
<div class="img-wrap">
<img itemprop="image" src="http://static.stereogum.com/uploads/2015/01/post-rock-promo-293x193.jpg" width="293" height="193" alt="30 Essential Post-Rock Songs">
</div>
<div class="title">
<div>30 Essential Post-Rock Songs</div>
</div>
</div>
</a>
<a href="http://www.stereogum.com/1719309/26-essential-songs-from-the-nyc-rock-resurgence/franchises/ultimate-playlist/">
<div class="post col-sm-4">
<div class="img-wrap">
<img itemprop="image" src="http://static.stereogum.com/uploads/2014/11/garage-rock-promo-293x193.jpg" width="293" height="193" alt="26 Essential Songs From The NYC Rock Resurgence">
</div>
<div class="title">
<div>26 Essential Songs From The NYC Rock Resurgence</div>
</div>
</div>
</a>
<a href="http://www.stereogum.com/1685920/30-essential-songs-from-the-golden-era-of-emo/franchises/ultimate-playlist/">
<div class="post col-sm-4">
<div class="img-wrap">
<img itemprop="image" src="http://static.stereogum.com/uploads/2014/07/emo-promo-293x193.jpg" width="293" height="193" alt="30 Essential Songs From The Golden Era Of Emo">
</div>
<div class="title">
<div>30 Essential Songs From The Golden Era Of Emo</div>
</div>
</div>
</a>
</div>
</div>
</div>
<footer id="footer">
<div class="container">
<div class="comscore">
<div class="comscore-header clearfix">
<div class="right">
<div class="mobile-site-footer">
</div>
<div class="footer-logo">
<a href="/">
<img src="http://assets.stereogum.com/wp-content/themes/stereogum/assets/images/logo-white.svg" width="200" height="16"/>
</a>
</div>
</div>
<div class="left">
<ul class="social-links">
<li>
<a href="http://www.facebook.com/Stereogum" target="_blank">
<div class="social-icon square facebook">
<span class="icon-facebook"></span>
</div>
</a>
</li>
<li>
<a href="http://www.twitter.com/stereogum" target="_blank">
<div class="social-icon square twitter">
<span class="icon-twitter"></span>
</div>
</a>
</li>
</ul>
<div class="menu">
<a href="http://www.stereogum.com/features" alt="features">FEATURES</a>
<a href="http://www.stereogum.com/music" alt="SONGS">SONGS</a>
<a href="http://www.stereogum.com/video" alt="VIDEOS">VIDEOS</a>
<a href="http://www.stereogum.com/category/franchises/list" alt="LISTS">LISTS</a>
<a href="/cdn-cgi/l/email-protection#9eeaf7eeeddeedeafbecfbf1f9ebf3b0fdf1f3" alt="CONTACT US">CONTACT US</a>
</div>
<span class="site-name">Stereogum</span>.com is a member of Billboard Music, a division of Billboard-Hollywood Reporter Media Group.
<div class="comscore-header-links">
<a class="comscore--link comscore--header-link" href="/about" rel="nofollow">About <span class="comscore--bold">Stereogum</span></a>
<a class="comscore--link comscore--header-link" href="/privacy-policy" rel="nofollow" target="_blank">Privacy Policy</a>
<a class="comscore--link comscore--header-link" href="/about-our-ads" rel="nofollow" target="_blank" class="cs_aboutBug">
<img src="//lib.pgmcdn.com/choices/collisionadmarkerwht.png" alt="adChoices" class="comscore--img">
</a>
<a class="comscore--link" href="/copyright" rel="nofollow" target="_blank">Copyright</a>
</div>
</div>
</div>
<div class="comscore--body">
<a class="comscore--link" href="http://www.billboard.com" target="_blank">Billboard</a> |
<a class="comscore--link" href="http://www.hollywoodreporter.com/" target="_blank" rel="nofollow">The Hollywood Reporter</a> |
<a class="comscore--link" href="http://www.spin.com/" target="_blank" rel="nofollow">SPIN</a> |
<a class="comscore--link" href="http://www.vibe.com/" target="_blank" rel="nofollow">VIBE</a> |
<a class="comscore--link" href="http://www.deathandtaxesmag.com/" target="_blank" rel="nofollow">deathandtaxesmag</a> |
<a class="comscore--link" href="http://www.stereogum.com/" target="_blank" rel="nofollow">Stereogum</a>
</div>
</div>
</div>
</footer>
<script type="text/javascript">
        // Asynchronous Loading
        var script = document.createElement("script");
        script.src = script.src = document.location.protocol + '//platform.twitter.com/widgets.js';
        script.async = true;
        document.getElementsByTagName("body")[0].appendChild(script);
    </script>
<script id="ad_slot" type="text/template">
            <div class="ad_desktop" data-sizes="[[160,600],[300,250],[300,600]]" data-position="300c"></div>
        </script>
<div id="hidden_div" class="hidden"></div>
<div id="ad_native_instream" class="ad_desktop" data-sizes="[2,2]" data-position="native_instream_lazy"></div>
<div id="ad_native_rightrail" class="ad_desktop" data-sizes="[2,2]" data-position="native_detail_lazy"></div><script type="text/html" id="sc_interrupter_template">
<div class="post row wp-pi-sponsored-content-interrupter">
    <div class="posts-holder"> 
                    <div class="interrupter-post"> 
            <div class="image-holder"> 
            <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %> target="_blank" <% } %>> 
                <img src="<% if(typeof post_images == "object") { print(post_images.feed.split) } %>"> 
            </a> 
            <div class="text-overlay">
                <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %> target="_blank" <% } %>>
                    <% if(typeof promoted_text !== "undefined") { print(promoted_text) } else { print('Promoted') } %>
                </a>
            </div> 
        </div> 
        <div class="preview-holder"> 
                    <% if(open_blank_links && typeof shared_from_site !== "undefined" && shared_from_site) { %>
                <div class="shared-by">
                    <% if(typeof shared_from_text !== "undefined") { print(shared_from_text) } %> <a href="<% if(typeof shared_from_link !== "undefined") { print(shared_from_link) } %>" target="_blank"><% if(typeof shared_from_site !== "undefined") { print(shared_from_site) } %></a>
                </div>
            <% } %>    
                <h2> 
            <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %> target="_blank" <% } %>> 
                <% if(typeof post_title !== "undefined") { print(post_title) } %>
            </a> 
        </h2> 
        <% if(typeof sponsor_image !== "undefined") { %>
            <div class="sponsor"> 
                                <% if(typeof show_sponsor !== "undefined" && !show_sponsor && typeof sponsor_text !== "undefined") { print(sponsor_text) } %>

                <a href="<% if(typeof sponsor_link !== "undefined") { print(sponsor_link) } %>" target="_blank">
                    <img src="<% if(typeof sponsor_image !== "undefined") { print(sponsor_image) } %>" alt="">
                </a> 
                
                                <% if((typeof show_sponsor === "undefined" || show_sponsor )
                        && typeof sponsor_name !== "undefined") { %>
                    <% if(typeof sponsor_text !== "undefined") { print(sponsor_text) } %>
                    <a href="<% if(typeof sponsor_link !== "undefined") { print(sponsor_link) } %>" target="_blank">
                        <span>
                            <% if(typeof sponsor_name !== "undefined") { print(sponsor_name) } %>
                        </span>
                    </a> 
                <% } %>
            </div> 
        <% } %>
                <div class="preview"> 
            <% if(typeof post_preview !== "undefined") { print(post_preview) } %>
        </div> 
            </div> 
</div>            </div> 
</div>
</script><script type="text/html" id="sc_interrupter_template_sidebar">
<div class="sidebar-module wp-pi-sponsored-content-interrupter"> 
    <div class="title-holder clearfix"> 
                    <div class="title left"> 
                <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %>target="_blank"<% } %>>
                    <h3>
                        <% if(typeof promoted_text !== "undefined") { print(promoted_text) } else { print('Promoted') } %>
                    </h3>
                </a>
            </div> 
            </div> 
    <div class="posts-holder"> 
        <div class="interrupter-post"> 
            <div class="image-holder"> 
                <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %>target="_blank"<% } %>> 
                    <img src="<% if(typeof post_images == "object") { print(post_images.sidebar) } %>">
                </a> 
            </div> 
            <div class="preview-holder"> 
                                    <% if(open_blank_links && typeof shared_from_site !== "undefined" && shared_from_site) { %>
                        <div class="shared-by">
                            <% if(typeof shared_from_text !== "undefined") { print(shared_from_text) } %> <a href="<% if(typeof shared_from_link !== "undefined") { print(shared_from_link) } %>" target="_blank"><% if(typeof shared_from_site !== "undefined") { print(shared_from_site) } %></a>
                        </div>
                    <% } %>    
                                <h2> 
                    <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %>target="_blank"<% } %>>
                        <% if(typeof post_title !== "undefined") { print(post_title) } %>
                    </a> 
                </h2> 
                <% if(typeof sponsor_image !== "undefined") { %>
                     
                        <div class="sponsor">
                                                        <% if(typeof show_sponsor !== "undefined" && !show_sponsor && typeof sponsor_text !== "undefined") { print(sponsor_text) } %> 
                            
                            <a href="<% if(typeof sponsor_link !== "undefined") { print(sponsor_link) } %>" target="_blank">
                                <img src="<% if(typeof sponsor_image !== "undefined") { print(sponsor_image) } %>" alt="">
                            </a> 
                            <% if((typeof show_sponsor === "undefined" || show_sponsor)
                                    && typeof sponsor_name !== "undefined") { %>
                                <% if(typeof sponsor_text !== "undefined") { print(sponsor_text) } %> 
                                <a href="<% if(typeof sponsor_link !== "undefined") { print(sponsor_link) } %>" target="_blank">
                                    <span>
                                        <% if(typeof sponsor_name !== "undefined") { print(sponsor_name) } %>
                                    </span>
                                </a> 
                            <% } %>
                        </div> 
                     
                <% } %>
            </div> 
        </div> 
    </div> 
</div>
</script> <style>#pi-fb-oauth-error-dialog{text-align:center!important;}</style>
<div id="fb-root"></div>
<div id="pi-fb-oauth-error-dialog" title="FACEBOOK WARNING" class="pi-fb-oauth-popup" style="text-align: center;">
<div style="clear: both"></div>
<span id="pi-fb-oauth-error-dialog-message" style="font-size: 14px;">&nbsp;</span>
 
<div class="ui-dialog-buttonset">
<button style="top: 80px;left: 80px;" type="button" class="close-pi-fb-oauth-error-dialog ui-button ui-widget ui-state-default ui-corner-all ui-button-text-only" role="button" aria-disabled="false">
<span class="ui-button-text">Close</span>
</button>
</div>
</div>
<script type="text/javascript">
            var PI_OAUTH_FACEBOOK_APP_ID = '248953356872';
            var PI_OAUTH_FACEBOOK_SCOPE = '';
            var PI_OAUTH_FACEBOOK_ERROR_CALLBACK = typeof(piLoginShowErrorMassage) == 'function' ? piLoginShowErrorMassage : '';
        </script>
<div class="ad_desktop" data-position='out_of_page' data-sizes='[[1,1]]' data-lazy-load='0' data-refresh='0' data-refresh-timer='0' data-swap='' data-load-order='3' data-out-of-page='true' style="display: none;">
</div>
<script>CLARITY.push({use:['ads'],run:function(Ads){Ads.site_code="stereogum";if(!Ads.zone){Ads.zone="article_page";}
var keywords=[];keywords.push({keywords:"",keyvalues:"post_id=1934129",paths:"",positions:"all"});keywords.push({keywords:"",keyvalues:"category=news",paths:"",positions:"all"});keywords.push({keywords:"",keyvalues:"tags=rock-and-roll-hall-of-fame,snoop-dogg,tupac-shakur",paths:"",positions:"all"});keywords.push({keywords:"",keyvalues:"url=d19cb650",paths:"",positions:"all"});keywords.push({keywords:"",keyvalues:"pagetype=article_page",paths:"",positions:"all"});Ads.keywords=keywords;Ads.optionDefaults=Ads.optionDefaults||{};Ads.autoPopulate();}});</script><div class="pi-login-popups" style="display: none">
<div id="sign-in-dialog" title="Sign In:" class="pi-login-popup">
<div style="clear: both"></div>
<span id="lPiLogin_Status">&nbsp;</span>
<div class="login-response-text"></div>
<div class="login-form">
<form name="PiLogin_Form" id="PiLogin_Form" action="#" method="post">
<div>
<div class="restore2 input-holder">
<label>Username</label>
<input type="text" name="PiLoginName" id="lPiLoginName" class="input"/>
</div>
<div class="restore2 input-holder">
<label>Password</label>
<input type="password" name="PiLoginPass" id="lPiLoginPass" class="input" value=""/>
</div>
<div>
<input type="hidden" name="redirect_to" id="redirect_to" value=""/>
</div>
</div>
<div class="form-input-links">
<div class="remember-my-checkbox">
<input type="checkbox" name="PiLoginRemember" id="lPiLoginRemember" checked="checked" value="1"/>
<span>Remember me &nbsp;</span>
</div>
<div class="links-right">
<div style="display: inline-block;">Not a member?</div>
<div style="display: inline-block;; padding-left: 5px;"><a class="sign-up-link" href="#">Sign Up</a> / <a class="forgot-link" href="#">Forgot your password?</a></div>
</div>
<div class="links-left"><a href="" onclick="fb_start_login(); return false;" class="fb_oauth2_login" title="Sign in with Facebook">Sign in with Facebook</a></div>
<div style="clear:both;float:none;"></div>
</div>
</form>
</div>
</div>
<div id="sign-up-dialog" title="Sign Up:" class="pi-login-popup">
<div style="clear: both"></div>
<span id="rPiLogin_Status">&nbsp;</span>
<div class="login-response-text"></div>
<div class="login-form">
<form name="PiSignon_Form" id="PiSignon_Form" action="#" method="post">
<div class="register-form">
<div class="input-holder">
<label>
Email
</label>
<input type="text" name="email" id="a_email" class="input"/>
</div>
<div class="input-holder">
<label>
Username
</label>
<input type="text" name="user_login" id="a_user_login" class="input"/>
</div>
</div>
<div class="register-form">
<div class="input-holder">
<label>
Password
</label>
<input type="password" name="pass1" id="a_pass1" class="input" value=""/>
</div>
<div class="input-holder">
<label>
Confirm Password
</label>
<input type="password" name="pass2" id="a_pass2" class="input" value=""/>
</div>
</div>
<div class="sign-up-fb-2"><a href="" onclick="fb_start_login(); return false;" class="fb_oauth2_login" title="Sign in with Facebook">Sign in with Facebook</a> </div>
<input type="hidden" name="redirect_to" value="http:// "/>
<div class="form-input-links">Already a member? <a class="sign-in-link" href="#">Sign In</a></div>
</form>
</div>
</div>
<div id="forgot-dialog" title="Restore password:" class="pi-login-popup">
<div style="clear: both"></div>
<span id="fPiLogin_Status">&nbsp;</span>
<div class="login-response-text"></div>
<div class="login-form">
<form name="PiForgot_Form" id="PiForgot_Form" action="#" method="post">
<div class="restore input-holder">
<label>Please enter your account email address, we'll send you an email with instructions to reset your password:</label>
<br/><br/>
<input type="text" name="PiLoginEmail" id="fPiLoginEmail" class="input"/>
<br/><br/>
<div class="g-recaptcha" data-sitekey="6LfKVRcTAAAAAGVoC_uNf5P1uE_JY9X7V2-4_mKL"></div>
</div>
<input type="hidden" name="redirect_to" value="http:// "/>
<div class="form-input-links rest"><a class="sign-in-link" href="#">Cancel</a></div>
</form>
</div>
</div>
</div>
<script type="text/html" id="pe_zoom_overlay">
        <div class="pe-zoom-overlay scroll-<%= scroll_dir %>">
            <div class="image-holder">
                <img itemprop="image"
                     src="<%= img_src %>">
            </div>
            <div class="pe-zoom-close-x"></div>
        </div>
    </script><script type='text/javascript' src='http://www.stereogum.com/wp-content/plugins/akismet/_inc/form.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<link rel='stylesheet' id='ad-css-css' href='http://assets.stereogum.com/wp-content/plugins/wp-pi-clarity/css/clarity.css?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5' type='text/css' media='all'/>
<link rel='stylesheet' id='photo-zoom-css' href='http://assets.stereogum.com/wp-content/plugins/wp-pi-mainembed/css/photo-zoom.css?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5' type='text/css' media='all'/>
<link rel='stylesheet' id='zergnet-article-css-css' href='http://assets.stereogum.com/wp-content/plugins/wp-pi-zergnet/css/article.css?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5' type='text/css' media='all'/>
<script type='text/javascript'>
/* <![CDATA[ */
var mobileDetect = {"isMobile":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.stereogum.com/wp-content/plugins/wp-pi-mobile-theme/js/mobile_detect.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://assets.stereogum.com/wp-content/plugins/wp-pi-music-player/js/soundcloud.sdk.4.0.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var localize = {"ajaxurl":"http:\/\/www.stereogum.com\/wp\/wp-admin\/admin-ajax.php","soundcloud_client_id":"3289dfd5994e22ec60c5bd8f9a877275"};
/* ]]> */
</script>
<script type='text/javascript' src='http://assets.stereogum.com/wp-content/plugins/wp-pi-music-player/js/playlist.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://assets.stereogum.com/wp-content/plugins/wp-pi-music-player/js/player.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://assets.stereogum.com/wp-content/plugins/wp-pi-spinmedia-core/js/vendor/img-touch-canvas.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.stereogum.com/wp/wp-includes/js/wp-util.min.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://assets.stereogum.com/wp-content/plugins/wp-pi-spinmedia-core/js/mobile-zoom.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://www.stereogum.com/wp/wp-includes/js/jquery/ui/core.min.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://www.stereogum.com/wp/wp-includes/js/jquery/ui/widget.min.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://www.stereogum.com/wp/wp-includes/js/jquery/ui/mouse.min.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://www.stereogum.com/wp/wp-includes/js/jquery/ui/resizable.min.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://www.stereogum.com/wp/wp-includes/js/jquery/ui/draggable.min.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://www.stereogum.com/wp/wp-includes/js/jquery/ui/button.min.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://www.stereogum.com/wp/wp-includes/js/jquery/ui/position.min.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://www.stereogum.com/wp/wp-includes/js/jquery/ui/dialog.min.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://www.stereogum.com/wp-content/plugins/wp-pi-fb-oauth/pi-fb-oauth.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='//www.google.com/recaptcha/api.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var the_ajax_script = {"ajaxurl":"http:\/\/www.stereogum.com\/wp\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://assets.stereogum.com/wp-content/plugins/wp-pi-login/js/login.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://assets.stereogum.com/wp-content/plugins/wp-pi-sponsored-content/js/interrupter/interrupter.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='https://maxcdn.bootstrapcdn.com/bootstrap/3.2.0/js/bootstrap.min.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://assets.stereogum.com/wp-content/plugins/wp-pi-spinmedia-core/js/vendor/lodash.2.4.1.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://www.stereogum.com/wp-content/themes/wp-theme-base/assets/js/all.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://www.stereogum.com/wp-content/themes/stereogum/assets/js/all.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var commentVotingVars = {"guestVoting":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.stereogum.com/wp-content/plugins/wp-pi-comment-voting/js/comment-vote.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://www.stereogum.com/wp/wp-includes/js/wp-embed.min.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://www.stereogum.com/wp-content/plugins/wp-pi-sharrre/js/jquery.sharrre.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://www.stereogum.com/wp-content/plugins/wp-pi-sharrre/js/sharrre-init.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://assets.stereogum.com/wp-content/plugins/wp-pi-clarity/js/sticky.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://assets.stereogum.com/wp-content/plugins/wp-pi-mainembed/js/photo-zoom.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://assets.stereogum.com/wp-content/plugins/wp-pi-comments/js/jquery.validate.pack.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://assets.stereogum.com/wp-content/plugins/wp-pi-comments/js/comments.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://www.stereogum.com/wp/wp-includes/js/jquery/ui/tooltip.min.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_comments_vars = {"ajaxurl":"http:\/\/www.stereogum.com\/ajax","post_id":"1934129","registrationRequired":"1","is_mobile":"","signout_link":"http:\/\/www.stereogum.com\/\/wp\/wp-login.php?action=logout&_wpnonce=38127475a8&redirect_to=http%3A%2F%2Fwww.stereogum.com%2F1934129%2Fwatch-snoop-dogg-induct-tupac-shakur-into-the-rock-and-roll-hall-of-fame%2Fnews%2F","siteurl":"http:\/\/www.stereogum.com\/wp","getoEmbeds":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://assets.stereogum.com/wp-content/plugins/wp-pi-comments/js/comments_ajax.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://assets.stereogum.com/wp-content/plugins/wp-pi-spinmedia-widgets/js/widgets-aggregator.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://assets.stereogum.com/wp-content/plugins/wp-pi-campaign-monitor/js/campaign_monitor.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script type='text/javascript' src='http://assets.stereogum.com/wp-content/plugins/wp-pi-music-player/js/player-integration.js?ver=8fc7fede9fd1e5e28005d4f393fdc44851c131d5'></script>
<script>/* <![CDATA[ */(function(d,s,a,i,j,r,l,m,t){try{l=d.getElementsByTagName('a');t=d.createElement('textarea');for(i=0;l.length-i;i++){try{a=l[i].href;s=a.indexOf('/cdn-cgi/l/email-protection');m=a.length;if(a&&s>-1&&m>28){j=28+s;s='';if(j<m){r='0x'+a.substr(j,2)|0;for(j+=2;j<m&&a.charAt(j)!='X';j+=2)s+='%'+('0'+('0x'+a.substr(j,2)^r).toString(16)).slice(-2);j++;s=decodeURIComponent(s)+a.substr(j,m-j)}t.innerHTML=s.replace(/</g,'&lt;').replace(/\>/g,'&gt;');l[i].href='mailto:'+t.value}}catch(e){}}}catch(e){}})(document);/* ]]> */</script></body>
</html>